Bug #946

avatar

Reconnect issue with server and channel passwords

Added by Josh Berkus 3804 days ago. Updated 3785 days ago.

Status:Closed Start:01/24/2014
Priority:Normal Due date:
Assigned to:avatarMirco Bauer % Done:

0%

Category:Engine IRC
Target version:-
Complexity:

Found in Version:

0.10

Votes: 0

Description

Setup:

IRC server with:
(a) password for server
(b) SSL
(c) channel passwords for each channel

All-in-one desktop Smuxi client on Gnome/Ubuntu laptop with channel JOINs as "on-connect" commands. Server is auto-connect on start.

1. Start Smuxi and connect to server.

2. Put laptop in suspend, or disconnect it from the network.

3. Wake laptop back up or reconnect the network.

4. Smuxi will not auto-reconnect to the server.

5. On a manual reconnect to the server, Smuxi will not rejoin the channels; the channels will be displayed, but you will not be connected to them.

6. If you try to join the channels with a manual /join command, you will get an error from Smuxi that you are already in that channel.

7. The only way to get back in the channels is to disconnect from the server entirely (losing all history) and reconnect.


Related issues

related to Smuxi - Bug #921 smuxi doesn't re-join some channels correctly Closed 12/23/2013

History

Updated by Mirco Bauer 3804 days ago

avatar

This sounds like the bug in #921 which was already fixed. Please try a daily build of Smuxi and see if the issue goes away.

Updated by Mirco Bauer 3804 days ago

avatar
  • Category set to Engine IRC
  • Assigned to set to Mirco Bauer

Updated by Mirco Bauer 3803 days ago

avatar
  • Status changed from New to Feedback

Updated by Josh Berkus 3785 days ago

avatar

THis is confirmed fixed in the current 0.11 daily.

Updated by Mirco Bauer 3785 days ago

avatar
  • Status changed from Feedback to Closed

Great. Thanks for the feedback.

Also available in: Atom PDF