Bug #928

avatar

Exception: Cannot cast from source type to destination type.

Added by Joey Stanford 2145 days ago. Updated 1371 days ago.

Status:Feedback Start:01/02/2014
Priority:Urgent Due date:
Assigned to:avatarMirco Bauer % Done:

0%

Category:Engine
Target version:TBD
Complexity:

Found in Version:

Votes: 0

Description

Exception Type:
System.InvalidCastException

Exception Message:
Cannot cast from source type to destination type.

Exception StackTrace:
  at Smuxi.Frontend.Gnome.JoinWidget.InitNetworks (IList`1 networks) [0x000ce] in /build/buildd/smuxi-0.10/src/Frontend-GNOME/Views/JoinWidget.cs:138 
  at Smuxi.Frontend.Gnome.JoinWidget.ApplyConfig (Smuxi.Engine.UserConfig config) [0x00018] in /build/buildd/smuxi-0.10/src/Frontend-GNOME/Views/JoinWidget.cs:157 
  at Smuxi.Frontend.Gnome.MainWindow.ApplyConfig (Smuxi.Engine.UserConfig userConfig) [0x000cc] in /build/buildd/smuxi-0.10/src/Frontend-GNOME/MainWindow.cs:337 
  at Smuxi.Frontend.Gnome.Frontend.ApplyConfig (Smuxi.Engine.UserConfig userConfig) [0x00020] in /build/buildd/smuxi-0.10/src/Frontend-GNOME/Frontend.cs:729 
  at Smuxi.Frontend.Gnome.Frontend <SyncConfig>c__AnonStoreyF.<>m__1F (System.Object , System.EventArgs ) [0x00000] in /build/buildd/smuxi-0.10/src/Frontend-GNOME/Frontend.cs:1175 
  at Gtk.Application InvokeCB.Invoke () [0x00000] in <filename unknown>:0 
  at GLib.Timeout TimeoutProxy.Handler () [0x00000] in <filename unknown>:0 

Happened when I started smuxi.

smuxi.strace (1.1 MB) Joey Stanford, 01/02/2014 09:22 PM

History

Updated by Joey Stanford 2145 days ago

avatar

Updated by Mirco Bauer 2144 days ago

avatar

What is your exact Smuxi version? (check Help -> About) and it could be that your network or some other server detail is just numbers?

Updated by Mirco Bauer 2144 days ago

avatar
  • Category set to Engine
  • Status changed from New to Feedback
  • Assigned to set to Mirco Bauer
  • Priority changed from Normal to Urgent
  • Target version set to 0.10.1

Updated by Joey Stanford 2144 days ago

avatar

Mirco Bauer wrote:

What is your exact Smuxi version? (check Help -> About) and it could be that your network or some other server detail is just numbers?

It's from the Ubuntu PPA.

Vendor: Debian 0.10-1~saucy+1
Frontend: GNOME 0.10.0.0
Engine: 0.10.0.0

Updated by Joey Stanford 2144 days ago

avatar

This was happening all the time so network was not the issue. I also noticed that the left sidebar with the servers and channels was missing. I was able to quickly change to a different server and was able to access the preferences menu. I set the "Persistent Buffer Lines" value from 50000 to 5000 and I no longer have any errors. (at least not at the moment)

Updated by Joey Stanford 2144 days ago

avatar

Upon restarting I found that the errors have gone away but the server/channel list window will not display until I go into preferences and click ok. Really odd behaviour!

Updated by Mirco Bauer 1371 days ago

avatar
  • Target version changed from 0.10.1 to TBD

Also available in: Atom PDF