Bug #825

avatar

Error when connecting to FreeNode via ZNC

Added by Daniel Lo Nigro 4116 days ago. Updated 4109 days ago.

Status:Closed Start:03/18/2013
Priority:High Due date:
Assigned to:avatarMirco Bauer % Done:

100%

Category:Engine IRC
Target version:0.8.10.2
Complexity:

Found in Version:

0.8.10.12100

Votes: 0

Description

After connecting to FreeNode via ZNC I get the following:

23:18 [376 (EndOfMotd)] End of /MOTD command.
23:18 -!- Connection error! Reason: Object reference not set to an instance of an object
23:18 -!- Reconnecting to host.dan.cx...
23:18 -!- Disconnected from ZNC Freenode
Debug log is as follows:
2013-03-18 23:20:43,202 [IrcProtocolManager (znc.example.com:12345) listener] DEBUG TRACE - [smuxi-engine.dll] ProtocolManagerBase.OnConnected(e = System.EventArgs)
2013-03-18 23:20:43,203 [IrcProtocolManager (znc.example.com:12345) listener] DEBUG TRACE - [smuxi-engine.dll] Session.UpdateNetworkStatus()
2013-03-18 23:20:43,203 [Main] DEBUG TRACE - [smuxi-frontend-gnome.exe] MainWindow.UpdateTitle(chatView = (null), protocolStatus = '(No network connections)')
2013-03-18 23:20:43,204 [IrcProtocolManager (znc.example.com:12345) listener] DEBUG TRACE - [smuxi-engine.dll] ContactModel..ctor(id = 'Daniel15', identityName = 'Daniel15', networkID = 'ZNC Freenode', networkProtocol = 'IRC')
2013-03-18 23:20:43,205 [IrcProtocolManager (znc.example.com:12345) listener] DEBUG Smuxi.Engine.IrcProtocolManager - _OnRawMessage(): detected IRC network: 'freenode'
2013-03-18 23:20:43,525 [Main] DEBUG Smuxi.Frontend.Gnome.MessageTextView - OnMotionNotifyEvent(): at url tag
2013-03-18 23:20:43,548 [Main] DEBUG Smuxi.Frontend.Gnome.MessageTextView - OnMotionNotifyEvent(): not at url tag
2013-03-18 23:20:43,692 [IrcProtocolManager (znc.example.com:12345) listener] ERROR Smuxi.Engine.IrcProtocolManager - _Run(): exception in _Listen() occurred!
System.NullReferenceException: Object reference not set to an instance of an object
  at Meebey.SmartIrc4net.IrcClient._InterpretChannelMode (Meebey.SmartIrc4net.IrcMessageData ircdata, System.String mode, System.String parameter) [0x005c5] in /build/buildd/smuxi-0.8.10.12100/lib/SmartIrc4net/src/IrcClient/IrcClient.cs:1685 
  at Meebey.SmartIrc4net.IrcClient._Event_MODE (Meebey.SmartIrc4net.IrcMessageData ircdata) [0x00051] in /build/buildd/smuxi-0.8.10.12100/lib/SmartIrc4net/src/IrcClient/IrcClient.cs:2152 
  at Meebey.SmartIrc4net.IrcClient._HandleEvents (Meebey.SmartIrc4net.IrcMessageData ircdata) [0x001fd] in /build/buildd/smuxi-0.8.10.12100/lib/SmartIrc4net/src/IrcClient/IrcClient.cs:1271 
  at Meebey.SmartIrc4net.IrcClient._Worker (System.Object sender, Meebey.SmartIrc4net.ReadLineEventArgs e) [0x00000] in /build/buildd/smuxi-0.8.10.12100/lib/SmartIrc4net/src/IrcClient/IrcClient.cs:948 
  at (wrapper delegate-invoke) <Module>:invoke_void__this___object_ReadLineEventArgs (object,Meebey.SmartIrc4net.ReadLineEventArgs)
  at (wrapper delegate-invoke) <Module>:invoke_void__this___object_ReadLineEventArgs (object,Meebey.SmartIrc4net.ReadLineEventArgs)
  at Meebey.SmartIrc4net.IrcConnection.ReadLine (Boolean blocking) [0x00097] in /build/buildd/smuxi-0.8.10.12100/lib/SmartIrc4net/src/IrcConnection/IrcConnection.cs:880 
  at Meebey.SmartIrc4net.IrcConnection.Listen (Boolean blocking) [0x0000b] in /build/buildd/smuxi-0.8.10.12100/lib/SmartIrc4net/src/IrcConnection/IrcConnection.cs:819 
  at Meebey.SmartIrc4net.IrcConnection.Listen () [0x00000] in /build/buildd/smuxi-0.8.10.12100/lib/SmartIrc4net/src/IrcConnection/IrcConnection.cs:833 
  at Smuxi.Engine.IrcProtocolManager._Listen () [0x00000] in /build/buildd/smuxi-0.8.10.12100/src/Engine-IRC/Protocols/Irc/IrcProtocolManager.cs:1996 
2013-03-18 23:20:43,695 [IrcProtocolManager (znc.example.com:12345) listener] DEBUG TRACE - [smuxi-engine-irc.dll] IrcProtocolManager.Reconnect(fm = Smuxi.Engine.FrontendManager)
2013-03-18 23:20:43,695 [IrcProtocolManager (znc.example.com:12345) listener] DEBUG Smuxi.Engine.ProxySettings - GetWebProxy(<ircs://znc.example.com:12345/>): returning no proxy
2013-03-18 23:20:43,698 [IrcProtocolManager (znc.example.com:12345) listener] DEBUG TRACE - [smuxi-engine-irc.dll] IrcProtocolManager._OnDisconnected(sender = Meebey.SmartIrc4net.IrcFeatures, e = System.EventArgs)
2013-03-18 23:20:43,699 [IrcProtocolManager (znc.example.com:12345) listener] DEBUG TRACE - [smuxi-engine.dll] ProtocolManagerBase.OnDisconnected(e = System.EventArgs)

Version info:
Vendor: Debian 0.8.10.12100-1ubuntu2
Frontend: GNOME 0.8.10.12100
Engine: 0.8.10.12100

Associated revisions

Revision 13c47d4a340329414dd46abc32d4e370a762d5e3
Added by Mirco Bauer 4110 days ago

[lib/SmartIrc4net] Updated to fix a connection crash with ZNC bouncers (closes: #825)

History

Updated by Daniel Lo Nigro 4116 days ago

avatar

Just confirmed I get the same error while connecting to OFTC, so it's not specific to FreeNode.

Updated by Daniel Lo Nigro 4115 days ago

avatar

Okay I'm back with more information.

In Smuxi -> File -> Preferences -> Connection, I had "Nickname" set to "Daniel15" (uppercase D)
In ZNC, I had my nickname set to "daniel15" (lowercase D)

Once I changed them to match (ie. changed Smuxi to be lowercase), it started working. I'm guessing a string comparison in SmartIrc4net is case-sensitive when it shouldn't be, or something like that.

Updated by Mirco Bauer 4110 days ago

avatar
  • Category set to Engine IRC
  • Assigned to set to Mirco Bauer
  • Priority changed from Normal to High
  • Target version set to 0.8.10.2

Updated by Mirco Bauer 4110 days ago

avatar
  • Status changed from New to Closed
  • % Done changed from 0 to 100

Updated by Mirco Bauer 4110 days ago

avatar

Please try a daily build >= 0.8.11+git-0~207~* from: https://smuxi.im/documentation/running-from-git/ and see if it works now.

Updated by Daniel Lo Nigro 4109 days ago

avatar

Confirmed fixed with 0.8.11+git-0~207~quantal1 :)

Updated by Mirco Bauer 4109 days ago

avatar

Thanks for the confirmation!

Also available in: Atom PDF