Bug #239

avatar

| can't be used as part of the nick in preferences -> connection -> nickname

Added by Perry Mason 3498 days ago. Updated 1974 days ago.

Status:New Start:11/20/2009
Priority:Normal Due date:
Assigned to:avatarMirco Bauer % Done:

0%

Category:Engine
Target version:TBD
Complexity:

High

Found in Version:

Votes: 0

Description

meebey|FixingBugs will be saved as meebey FixingBugs

History

Updated by Mirco Bauer 3498 days ago

avatar
  • Category set to Engine
  • Assigned to set to Mirco Bauer

Thats a bug in the config backend which uses "|" as separation character for lists, like nicknames.

Updated by Mirco Bauer 3463 days ago

avatar
  • Target version set to 0.8

Updated by David Paleino 3456 days ago

avatar

Mirco, what do you think about using some non-printable character for this? Say, like \0.
I agree that this makes the configuration file less hand-editable though.

/me wanting to hack on Smuxi again \o/ \o/ \o/

Updated by Mirco Bauer 3456 days ago

avatar

David Paleino wrote:

Mirco, what do you think about using some non-printable character for this? Say, like

LOL a redmine bug chokes on your \0 ^^

That would surely work but makes it incompatible with older versions. I
thought about escaping the | character with some other char... but I think in the long run I will just replace that pure INI hack with some proper config backend, say XML/YAML class serialization. So IMHO not worth it to add more hacks to this for now, better replace it with something proper.

Updated by Mirco Bauer 3452 days ago

avatar
  • Complexity set to High

Updated by Mirco Bauer 3239 days ago

avatar
  • Target version changed from 0.8 to TBD

This needs a new config backend which is postponed to 0.9

Also available in: Atom PDF