Bug #1011

avatar

Unclear information how to install only server

Added by Andre n 1534 days ago.

Status:New Start:01/05/2015
Priority:Normal Due date:
Assigned to:avatarMirco Bauer % Done:

0%

Category:Website
Target version:-
Complexity:

Found in Version:

Votes: 0

Description

Neither in Download (HOW TO GET) or the FAQ page there is information what to install if i just want install certain components.
A valid szenario for these would be to install on the server only the engine with its protocolls and not the frontends (at least not the GUI)

After installing smuxi-engine on wheezy from pbo with the following command:
apt-get -t wheezy-backports install smuxi-engine

there are still a plenty of packages difference to the smuxi meta-package:

Suggested packages:
  aspell-doc spellutils ispell emacsen-common jed-extra gconf-defaults-service hunspell
  openoffice.org-hunspell openoffice.org-core libasound2-plugins libcanberra-gtk0
  libcanberra-pulse libenchant-voikko libgd-tools monodoc-gtk2.0-manual gphoto2 gtkam gvfs
  avahi-daemon hpoj hplip unpaper
The following packages will be REMOVED:
  libgd2-noxpm
The following NEW packages will be installed:
  acl aspell aspell-en colord consolekit dbus-x11 dconf-gsettings-backend dconf-service
  dictionaries-common enchant gconf-service gconf2 gconf2-common hunspell-en-us libasound2
  libaspell15 libatk1.0-0 libatk1.0-data libcairo-gobject2 libcanberra-gtk3-0
  libcanberra-gtk3-module libcanberra0 libck-connector0 libcolord1 libdbus-glib-1-2
  libdbus-glib1.0-cil libdbus1.0-cil libdbusmenu-glib4 libdconf0 libenchant1c2a
  libfile-copy-recursive-perl libgconf-2-4 libgd2-xpm libglade2-0 libglade2.0-cil
  libglib2.0-cil libgphoto2-2 libgphoto2-l10n libgphoto2-port0 libgtk-3-0 libgtk-3-bin
  libgtk-3-common libgtk2.0-0 libgtk2.0-bin libgtk2.0-cil libgtk2.0-common libgtkspell0
  libgudev-1.0-0 libgusb2 libhunspell-1.3-0 libieee1284-3 libindicate0.1-cil libindicate5
  libmono-cairo4.0-cil libnotify0.4-cil libogg0 libpam-ck-connector libpolkit-agent-1-0
  libpolkit-backend-1-0 libpolkit-gobject-1-0 libsane libsane-common libsane-extras
  libsane-extras-common libudev1 libv4l-0 libv4lconvert0 libvorbis0a libvorbisfile3
  libxcomposite1 libxcursor1 libxdamage1 libxfixes3 libxi6 libxinerama1 libxrandr2
  notification-daemon policykit-1 psmisc sane-utils smuxi smuxi-frontend-gnome
  ssh-askpass-gnome update-inetd
The following packages will be upgraded:
  udev
1 upgraded, 84 newly installed, 1 to remove and 53 not upgraded.
Need to get 23.8 MB/26.8 MB of archives.
After this operation, 113 MB of additional disk space will be used.

it is also not obvois what the difference between the certain frontend nor how to get them properly without all the packages available

Also available in: Atom PDF